[R-sig-Debian] Trouble updating to latest version of R

Dirk Eddelbuettel edd at debian.org
Mon Feb 1 04:33:55 CET 2010

On 31 January 2010 at 20:24, Hodgess, Erin wrote:
| Dear R Debian People:
| I'm trying to update a computer that I do not use often to the latest version of R.
| Here is the problem:
| debian:/home/erinh# apt-get -t unstable install r-base r-base-dev
| Reading package lists... Error!
| E: Dynamic MMap ran out of room
| E: Error occurred while processing uim-utils (NewVersion1)
| E: Problem with MergeList /var/lib/apt/lists/ftp.egr.msu.edu_debian_dists_etch_main_binary-i386_Packages
| E: The package lists or status file could not be parsed or opened.
| Does this look familiar, please?  Any suggestions for a fix, please?

Known apt limitation -- googling for 'Dynamic MMap ran out of room' (ie the
error message) along with 'apt' or 'apt-get' would you have told you so. In
fact, Google Chrome even completed the sentence for me.  So do the query and
follow the first hit


FWIW newer systems don't seem to use it. I can't find this in any of my
apt.conf files -- but I have needed it in the past.

Now, if I may: Please do not use this list for generic Debian help. It is for
the R / Debian intersection only.  We value our signal to noise ratio, so
let's all make an effort at keeping it high.


Three out of two people have difficulties with fractions.

More information about the R-SIG-Debian mailing list