[R-sig-Debian] lam vs. openmpi

Dirk Eddelbuettel edd at debian.org
Mon May 25 10:08:57 CEST 2009

On 24 May 2009 at 23:02, Erin Hodgess wrote:
| Dear R Debian Users:
| I wrote a quick C program (eventually to become R code) and compiled it as:
| mpicc -o greet greet.c
| So far so good.  Now when I run mpirun, this happens:
| erin at erin-laptop:~$ mpirun -np 2 greet
| -----------------------------------------------------------------------------
| It seems that there is no lamd running on the host erin-laptop.
| This indicates that the LAM/MPI runtime environment is not operating.
| The LAM/MPI runtime environment is necessary for the "mpirun" command.
| Please run the "lamboot" command the start the LAM/MPI runtime
| environment.  See the LAM/MPI documentation for how to invoke
| "lamboot" across multiple machines.
| -----------------------------------------------------------------------------
| I have both lam and openmpi installed on my Ubuntu 9.04.  What should
| I do to eliminate the lam issue, please?

Either by uninstalling the lam packages, and/or by calling the Open MPI
programs directly (which overrides the default values of the alternatives
system).  I.e.

	  mpicc.openmpi			instead of mpicc

	  mpirun.openmpi		instead of mpirun, or just use orterun

But unless you have a reason to use it, I'd just un-install all things lam.


| thanks,
| Erin
| -- 
| Erin Hodgess
| Associate Professor
| Department of Computer and Mathematical Sciences
| University of Houston - Downtown
| mailto: erinm.hodgess at gmail.com
| _______________________________________________
| R-SIG-Debian mailing list
| R-SIG-Debian at r-project.org
| https://stat.ethz.ch/mailman/listinfo/r-sig-debian

Three out of two people have difficulties with fractions.

More information about the R-SIG-Debian mailing list