[R-sig-Debian] rgl install failed...

Johannes Ranke jranke at uni-bremen.de
Tue May 19 17:53:46 CEST 2009


* Petar Milin <pmilin at ff.uns.ac.rs> [090517 11:40]:
> Hello, again!
> Sorry for being tedious, that's because of having no experience enough,  
> but I really want to learn.
> Please, let me know what I am doing wrong now; I did following:
> 1. apt-get install -t unstable r-cran-rgl
> 2. then, from R, tried to do install.packages("rgl"), but that failed  
> for same reasons as before:
>    checking for X... no
>    configure: error: X11 not found but required, configure aborted.
>    ERROR: configuration failed for package ?rgl?
> 3. then, I tried apt-get build-dep r-cran-rgl, and it went fine

well, what did it install? I just did the same on my machine, and it
wanted to remove nvidia-glx-dev, which provides the headers for the
proprietary driver I am using with my nvidia card, and it wanted to
install mesa headers. So if you use the nvidia driver like me, you
should not use the above line, but just apt-get install nvidia-glx-dev.
Works fine over here on lenny, using the R 2.9.0 from CRAN.


> 4. finally, back to install.packages("rgl"), and now it failed for some  
> other reasons:
>    checking for GL/glu.h... yes
>    checking for glEnd in -lGL... no
>    configure: error: missing required library GL
>    ERROR: configuration failed for package ?rgl?
> I think I did everything you said in your previous letters. Please, bear  
> with me and let me learn and fix this.
> Thank you. Best,
> PM
> _______________________________________________
> R-SIG-Debian mailing list
> R-SIG-Debian at r-project.org
> https://stat.ethz.ch/mailman/listinfo/r-sig-debian

Dr. Johannes Ranke                 jranke at uni-bremen.de

More information about the R-SIG-Debian mailing list