[R-sig-Debian] [R] New package Ryacas

Simon Blomberg blomsp at ozemail.com.au
Tue Oct 17 06:57:11 CEST 2006

Hi Gabor,

I'm running Quantian (Debian) inside a VMware virtual machine, on a 
Windows XP host.

I installed the latest version of yacas from the source tarball. I 
remembered to ./configure --enable-server to allow server connections. 
make and make install worked ok, after some fiddling. I checked that the 
yacas server option worked, by doing yacas --server 3333, and then 
telnet'ing to 3333 to check. It worked fine. I installed 
Ryacas. I then tried it out and got the following error:

 > library(Ryacas)
Loading required package: XML
 > yacas('Integrate(x)x;')
[1] "Starting Yacas!"
Error in socketConnection(host = "", port = 9734, server = 
       unable to open connection
In addition: Warning message: cannot be opened
 > Accepting requests from port 9734

I tried again (stubborn, I guess):                                       

 > yacas('Integrate(x)x;')
 [1] "Starting Yacas!"
 Accepting requests from port 9734
 YacasServer Could not bind to the socket
 : Address already in use
 /usr/local/lib/R/site-library/Ryacas/yacdir/R.ys(1) : File not found
 CommandLine(1) : Expecting ) closing bracket for sub-expression, but 
got x instead

Any ideas where I may be going wrong? I don't know anything about 
sockets. I've cross-posted to r-sig-debian. They may be interested.



Simon Blomberg, B.Sc.(Hons.), Ph.D, M.App.Stat. 
Centre for Resource and Environmental Studies
The Australian National University              
Canberra ACT 0200                               
T: +61 2 6125 7800 email: Simon.Blomberg_at_anu.edu.au
F: +61 2 6125 0757
CRICOS Provider # 00120C

The combination of some data and an aching desire for 
an answer does not ensure that a reasonable answer 
can be extracted from a given body of data.
- John Tukey.

More information about the R-SIG-Debian mailing list