[R-sig-Debian] dependency errors upgrading to 2.2.1-0sarge1

Michael Friendly friendly at yorku.ca
Fri Mar 31 15:52:45 CEST 2006

Dirk Eddelbuettel wrote:

> Michael,
> Let's start the other way around: what do you want to achieve?  What do you
> want to avoid? 

I wanted to be able to run a more recent R than my older 2.1.0, because 
I've run into situations where newer packages required a more recent R.
I guess that means testing for R, but stable for everything else, if 
that is possible, e.g., with apt pinning.

I thought it should be possible to upgrade r-base* from Debian stable at
   Cran while keeping the, presumably older, r-cran-* packages from the
older debian stable distribution.

But, apparently, r-recommended, which was to be upgraded by apt-get
depends on various r-cran packages,

   r-recommended: Depends: r-base-core (= 2.1.0-1) but 2.2.1-0sarge1 is 
to be installed
                  Depends: r-cran-kernsmooth (>= 2.2.14)
                  Depends: r-cran-lattice (>= 0.10.11)
                  Depends: r-cran-mgcv (>= 1.1.5)
                  Depends: r-cran-nlme (>= 3.1.52)
                  Depends: r-cran-rpart (>= 3.1.20)
                  Depends: r-cran-survival (>= 2.13.2-1)
                  Depends: r-cran-vr (>= 7.2.8)
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or 
specify a solution).

Fair enough, but I can't upgrade r-recommended now because of another
conflict with a file in r-base-latex (don't understand why the conflict):

   apt-get -f install
Reading Package Lists... Done
Building Dependency Tree... Done
Correcting dependencies... Done
The following extra packages will be installed:
The following packages will be upgraded:
1 upgraded, 0 newly installed, 0 to remove and 37 not upgraded.
2 not fully installed or removed.
Need to get 0B/6143kB of archives.
After unpacking 24.4MB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 125000 files and directories currently installed.)
Preparing to replace r-recommended 2.1.0-1 (using 
.../r-recommended_2.2.1-0sarge1_i386.deb) ...
Unpacking replacement r-recommended ...
dpkg: error processing 
/var/cache/apt/archives/r-recommended_2.2.1-0sarge1_i386.deb (--unpack):
  trying to overwrite `/usr/lib/R/library/grid/latex/Grid.tex', which is 
also in package r-base-latex
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)
euclid:~# dpkg-deb: subprocess paste killed by signal (Broken pipe)

So, what can I do now to rescue this?


Michael Friendly     Email: friendly AT yorku DOT ca
Professor, Psychology Dept.
York University      Voice: 416 736-5115 x66249 Fax: 416 736-5814
4700 Keele Street    http://www.math.yorku.ca/SCS/friendly.html
Toronto, ONT  M3J 1P3 CANADA

More information about the R-SIG-Debian mailing list