[R-sig-Debian] updating rgl on debian stable

Michael Friendly friendly at yorku.ca
Mon Dec 11 23:20:09 CET 2006

Running: R Version 2.3.1 (2006-06-01), debian stable

I'm testing an application that uses rgl (installed with apt-get install 
but fails, at least partly because that application uses a more current 
There is also a mysterious error msg from Xlib:

 > library(car)
 > library(rgl)
 > iris.mod <- lm(cbind(Sepal.Length, Sepal.Width, Petal.Length, 
Petal.Width) ~
+ Species, data=iris)
 > source("heplot.R")
 > source("heplot3d.R")
 > source("pairs.mlm.R")
 > heplot3d(iris.mod)
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
Error in ellipsoid(gmean, E, radius, col = last(col), label = "Error") :
        could not find function "asEuclidean"
 > capabilities()
    jpeg      png    tcltk      X11 http/ftp  sockets   libxml     fifo
    TRUE     TRUE     TRUE     TRUE     TRUE     TRUE     TRUE     TRUE
  cledit    iconv      NLS
    TRUE     TRUE     TRUE
 > sessionInfo()
Version 2.3.1 (2006-06-01)

attached base packages:
[1] "methods"   "stats"     "graphics"  "grDevices" "utils"     "datasets"
[7] "base"

other attached packages:
      rgl       car
"0.64-13"   "1.2-0"

If I run example(rgl) alone, things sort of work (I get the volcano data 
but I get the same Xlib: message:

 > example(rgl)
rgl> example(rgl.surface)
rgl.sr> data(volcano)
rgl.sr> rgl.clear()
Xlib:  extension "XFree86-DRI" missing on display ":0.0".

rgl.sr> rgl.surface(x, z, y, color = col)

I obtained the most recent source package for rgl and tried to install it
directly, but this fails.  Any idea what I can do?  How can I tell what X
component is being looked for?

euclid:/tmp# R CMD INSTALL rgl_0.69.tar.gz
* Installing *source* package 'rgl' ...
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking how to run the C preprocessor... gcc -E
checking for X... no
configure: error: X11 not found but required, configure aborted.
ERROR: configuration failed for package 'rgl'
** Removing '/usr/local/lib/R/site-library/rgl'

Is this what I need?
euclid:/tmp# aptitude search xfree86-dri
p   xfree86-driver-synaptics        - dummy package to upgrade to X.Org 
new modu

Michael Friendly     Email: friendly at yorku.ca 
Professor, Psychology Dept.
York University      Voice: 416 736-5115 x66249 Fax: 416 736-5814
4700 Keele Street    http://www.math.yorku.ca/SCS/friendly.html
Toronto, ONT  M3J 1P3 CANADA

More information about the R-SIG-Debian mailing list