[R-sig-DB] ORACLE driver Ubuntu

Luis Ridao Cruz Luisr at hav.fo
Mon Mar 1 14:28:16 CET 2010


Hi,

I already asked for help regarding the following topic. 
I have worked on it ever since but the problem is still unsolved.

I have installed an ODBC Driver for Linux (from the easySoft website)

I want to connect to our database through R via:




>library(RODBC)
> odbcDriverConnect("SERVER=IP_address:PORT;DRIVER=ORACLE;DATABASE=MAGNUS")
[1] -1
Warning messages:
1: In odbcDriverConnect("SERVER=IP_address:1521;DRIVER=ORACLE;DATABASE=MAGNUS") :
  [RODBC] ERROR: state IM002, code 0, message [unixODBC][Driver Manager]Data source name not found, and no default driver specified
2: In odbcDriverConnect("SERVER=IP_address:1521;DRIVER=ORACLE;DATABASE=MAGNUS") :
  ODBC connection failed

I tried several other possibilities, e.g. 

> odbcDriverConnect("SERVER=oserver:PORT;DRIVER=ORACLE;DATABASE=IP_address/MAGNUS")
 
but all of them fail

Attached are my odbc.ini and odbcinst.ini files.
Can anyone let me know how to fix this?


## file odbc.ini
[ORACLE]
driver		= Easysoft ODBC-Oracle WP
description		= Easysoft Oracle ODBC WP driver
server		= oserver
port		= 1521
sid		= xxx.xxx.xx.xxx/MAGNUS
user		= luisr
password		= myPassword
logging		= No
logfile		= 
enable_user_catalog		= yes
enable_synonyms		= yes
metadata_dont_change_case		= no
metadata_dont_do_schema		= no
metadata_id		= no
limit_long		= 0

## file odbcinst.ini
[Easysoft ODBC-Oracle WP]
Description		= Easysoft Oracle ODBC WP Driver
Driver		= /usr/local/easysoft/oraclewp/lib/libesorawp.so
Setup		= /usr/local/easysoft/oraclewp/lib/libesorawpS.so
Threading		= 0
FileUsage		= 1
DontDLClose		= 1
UsageCount		= 1


Running on Ubuntu 9.10 karmic

Thanks in advance




More information about the R-sig-DB mailing list