[R-pkg-devel] Debugging M1mac problems [solved]

Ivan Krylov |kry|ov @end|ng |rom |@@er@chem@m@u@ru
Fri Apr 9 11:11:53 CEST 2021

On Sat, 27 Mar 2021 17:26:16 +0300
Ivan Krylov <ikrylov using laser.chem.msu.ru> wrote:

> I'm probably doing something stupid with the file names that usually
> works but isn't guaranteed to work in all cases, but I cannot figure
> it out.

Long story short, the problem turned out to be that I called basename()
and dirname() on paths not guaranteed to exist. Thanks to Tomas
Kalibera for pointing me in the right direction!

I'd wager a guess that I would have reproduced the same issue on an
Intel macOS machine with Big Sur installed (this being the other main
difference between Intel/High Sierra machines where all tests passed
and the M1/Big Sur machine where they failed). The "package check
results" page now shows all "OK" for the updated version, so I must
have fixed it.

I guess the moral of the story is that sometimes, it's easier to fix a
problem than reproduce it for oneself.


More information about the R-package-devel mailing list