[R-pkg-devel] Replicate solaris errors

peter dalgaard pd@lgd @ending from gm@il@com
Sun Aug 12 00:18:53 CEST 2018

Have you tried asking CRAN for help? I mean, if you don't fix an obvious error, with a well-known cause, like the log thing, they'll get fed up and throw you off. However, fixing and then discovering an issue elsewhere is different, especially if you cannot easily reproduce it at your end. 


> On 11 Aug 2018, at 20:41 , Thibault Vatter <thibault.vatter using gmail.com> wrote:
> Yes, the non-portable call to log which causes the current build to fail on
> solaris has been corrected in a development version. However, the segfault
> that we don't understand and were asked to correct was present in the
> previous versions (e.g., and, and we believe that it
> is likely to reappear if we resubmit with only the non-portable log call
> corrected.
> This is why, in order to avoid resubmitting with the segfault still there
> and having the package removed from CRAN, we would like to be able to
> replicate the solaris build.
> On Sat, Aug 11, 2018 at 2:17 PM Iñaki Úcar <i.ucar86 using gmail.com> wrote:
>> El sáb., 11 ago. 2018 a las 19:30, Thibault Vatter
>> (<thibault.vatter using gmail.com>) escribió:
>>> Dear package developers,
>>> We've recently received an email letting us know that our package
>>> rvinecopulib (
>>> https://cran.r-project.org/web/packages/rvinecopulib/index.html) would
>> be
>>> removed from CRAN unless the errors from the solaris build were
>> corrected.
>>> Note that the package compile and the unit tests pass on the other test
>>> platforms from CRAN and even a local R devel build with ASAN / UBSAN
>>> sanitizers. On solaris, the package compiles but a segfault is produced
>> by
>>> one unit test for a reason that we still don't understand.
>> Are you talking about a new development version that is not still on
>> CRAN? Because the current CRAN version fails to install.
>> Iñaki
>>> To replicate the issue, I tried to mimic CRAN's solaris config (
>>> https://www.stats.ox.ac.uk/pub/bdr/Rconfig/r-patched-solaris-x86) in a
>>> virtual machine following the steps in the gist below (based on
>> Jeroen's):
>>> https://gist.github.com/tvatter/b2503f03fcd604ff764ffe4b979afcb6
>>> Note that the "--with-readline=no" configure option at the end was added
>>> because I got "configure: error: --with-readline=yes (default) and
>>> headers/libs are not available" without it.
>>> Unfortunately, I then got the "configure: error: a suitable iconv is
>>> essential" and could not proceed to build R.
>>> I know that I should get GNU iconv as specified in the installation
>> manual,
>>> hence the "/opt/csw/bin/pkgutil -y -i libiconv_dev" in the gist above. I
>>> verified that iconv is in /opt/csw/lib as expected and I thought that
>>> adding /opt/csw/lib to R_LD_LIBRARY_PATH as suggested in the manual would
>>> then do the trick, but it does not seem to be the case.
>>> Two questions:
>>> 1) What did I miss or do wrong?
>>> 2) Anyone found a way to replicate solaris CRAN builds to test packages?
>> I
>>> tried to use https://builder.r-hub.io/, but some of my package's
>>> dependencies fail to install because of udunits2 is missing on their
>> system
>>> if I recall correctly.
>>> Thibault
>>>        [[alternative HTML version deleted]]
>>> ______________________________________________
>>> R-package-devel using r-project.org mailing list
>>> https://stat.ethz.ch/mailman/listinfo/r-package-devel
> 	[[alternative HTML version deleted]]
> ______________________________________________
> R-package-devel using r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/r-package-devel

Peter Dalgaard, Professor,
Center for Statistics, Copenhagen Business School
Solbjerg Plads 3, 2000 Frederiksberg, Denmark
Phone: (+45)38153501
Office: A 4.23
Email: pd.mes using cbs.dk  Priv: PDalgd using gmail.com

More information about the R-package-devel mailing list