[R-pkg-devel] Replicate solaris errors

Iñaki Úcar i@uc@r86 @ending from gm@il@com
Sat Aug 11 20:17:28 CEST 2018

El sáb., 11 ago. 2018 a las 19:30, Thibault Vatter
(<thibault.vatter using gmail.com>) escribió:
> Dear package developers,
> We've recently received an email letting us know that our package
> rvinecopulib (
> https://cran.r-project.org/web/packages/rvinecopulib/index.html) would be
> removed from CRAN unless the errors from the solaris build were corrected.
> Note that the package compile and the unit tests pass on the other test
> platforms from CRAN and even a local R devel build with ASAN / UBSAN
> sanitizers. On solaris, the package compiles but a segfault is produced by
> one unit test for a reason that we still don't understand.

Are you talking about a new development version that is not still on
CRAN? Because the current CRAN version fails to install.


> To replicate the issue, I tried to mimic CRAN's solaris config (
> https://www.stats.ox.ac.uk/pub/bdr/Rconfig/r-patched-solaris-x86) in a
> virtual machine following the steps in the gist below (based on Jeroen's):
> https://gist.github.com/tvatter/b2503f03fcd604ff764ffe4b979afcb6
> Note that the "--with-readline=no" configure option at the end was added
> because I got "configure: error: --with-readline=yes (default) and
> headers/libs are not available" without it.
> Unfortunately, I then got the "configure: error: a suitable iconv is
> essential" and could not proceed to build R.
> I know that I should get GNU iconv as specified in the installation manual,
> hence the "/opt/csw/bin/pkgutil -y -i libiconv_dev" in the gist above. I
> verified that iconv is in /opt/csw/lib as expected and I thought that
> adding /opt/csw/lib to R_LD_LIBRARY_PATH as suggested in the manual would
> then do the trick, but it does not seem to be the case.
> Two questions:
> 1) What did I miss or do wrong?
> 2) Anyone found a way to replicate solaris CRAN builds to test packages? I
> tried to use https://builder.r-hub.io/, but some of my package's
> dependencies fail to install because of udunits2 is missing on their system
> if I recall correctly.
> Thibault
>         [[alternative HTML version deleted]]
> ______________________________________________
> R-package-devel using r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/r-package-devel

More information about the R-package-devel mailing list