[R-pkg-devel] Replicate solaris errors

Thibault Vatter thib@ult@v@tter @ending from gm@il@com
Sat Aug 11 19:30:15 CEST 2018

Dear package developers,

We've recently received an email letting us know that our package
rvinecopulib (
https://cran.r-project.org/web/packages/rvinecopulib/index.html) would be
removed from CRAN unless the errors from the solaris build were corrected.

Note that the package compile and the unit tests pass on the other test
platforms from CRAN and even a local R devel build with ASAN / UBSAN
sanitizers. On solaris, the package compiles but a segfault is produced by
one unit test for a reason that we still don't understand.

To replicate the issue, I tried to mimic CRAN's solaris config (
https://www.stats.ox.ac.uk/pub/bdr/Rconfig/r-patched-solaris-x86) in a
virtual machine following the steps in the gist below (based on Jeroen's):


Note that the "--with-readline=no" configure option at the end was added
because I got "configure: error: --with-readline=yes (default) and
headers/libs are not available" without it.

Unfortunately, I then got the "configure: error: a suitable iconv is
essential" and could not proceed to build R.

I know that I should get GNU iconv as specified in the installation manual,
hence the "/opt/csw/bin/pkgutil -y -i libiconv_dev" in the gist above. I
verified that iconv is in /opt/csw/lib as expected and I thought that
adding /opt/csw/lib to R_LD_LIBRARY_PATH as suggested in the manual would
then do the trick, but it does not seem to be the case.

Two questions:

1) What did I miss or do wrong?

2) Anyone found a way to replicate solaris CRAN builds to test packages? I
tried to use https://builder.r-hub.io/, but some of my package's
dependencies fail to install because of udunits2 is missing on their system
if I recall correctly.


	[[alternative HTML version deleted]]

More information about the R-package-devel mailing list