[R-pkg-devel] Help with R check

Boxuan Cui boxuancui at gmail.com
Sat Jan 6 18:36:20 CET 2018

Hi all,

*[Issue 1]*

This is the first time I have encountered this, and I have no idea what's
going on. I really appreciate anyone's help on this.

My package: https://cran.r-project.org/package=DataExplorer

My story:

   - *[Jan 01]*
      - I plan to release the latest version to CRAN. I ran all checks
      (including win-builder through *devtools::build_win()*) on my
      package, everything is OK, so I submitted it.
      - The URL for win-builder has expired, but in case you can find the
      check log: https://win-builder.r-project.org/D52z9NcU7633
      - AppVeyor build log:
      - Travis CI build log:
   - *[Jan 03]*
      - I was told that I need to update my MIT license file, since I made
      some changes there. I did as told and re-submit the package. I didn't
      change anything.
   - *[Jan 03 (later of the day)]*
      - My package is failing example checks on arch 'i386' for Windows,
      according to
      - Note the example was failing for *split_columns()*.
   - *[Jan 05]*
      - I saw the Email and did another *devtools::build_win()* with no
      changes at all.
      - I received the same error, but on another function, i.e.,
      - The check log is here:
   - *[Jan 05]*
      - After some investigation, I believe it is due to dependency
      versions, so I update DESCRIPTION with latest version for all,
including R
      (was 3.3.0).
      - This time the check log is showing a warning: *checking DESCRIPTION
      meta-information ... WARNING Dependence on R version '3.4.3' not with
      patchlevel 0*.
      - The check log is here:

Has anyone encountered this issue before?

*[Issue 2]*

Does anyone know how to remove these warnings for vignettes?
They happen on the following systems:

   - r-patched-solaris-x86
   - r-release-osx-x86_64
   - r-oldrel-osx-x86_64

Warning message:

*Warning in engine$weave(file, quiet = quiet, encoding = enc) :*
*     Pandoc (>= 1.12.3) and/or pandoc-citeproc not available. Falling back
to R Markdown v1.*
*    Warning in normalizePath(f2) :*
*     path[1]="./webshot3eaf50bf136e.png": No such file or directory*
*    Warning in file(con, "rb") :*
*     cannot open file './webshot3eaf50bf136e.png': No such file or
*    Quitting from lines 57-68 (dataexplorer-intro.Rmd) *
*    Error: processing vignette 'dataexplorer-intro.Rmd' failed with
*    cannot open the connection*
*    Execution halted *

After searching for the same warnings online, I found that vignettes (from
other pakcages) that loads JavaScript files tend to have these. Is there a
way to fix this?

Thank you very much for your time!

Boxuan (Bo)

	[[alternative HTML version deleted]]

More information about the R-package-devel mailing list