[R-pkg-devel] The Help (e.g. links) is not working for my packages

David.Kaethner at dlr.de David.Kaethner at dlr.de
Thu Aug 10 16:47:08 CEST 2017

Thank you for the replies!

First of all, here is the test package: 

Session info and the log of R CMD check at the end. There is an error: "LaTeX errors when creating PDF version." However, it says "checking Rd files ... OK".

I have tried the install now on 4 different computers (via devtools::install_github), they all did not work. 

Further points:
- Unfortunately, installation from a tarball did not work either. I build the tarball from the command line (Cygwin), then used R CMD, but tried it also from within RStudio ("Build Source Package", then "install.packages")
- I have managed to create another package WHICH WORKS. I have not been able to do it again though, I just don't know what I did differently.
- I played around with the documentation lines in the test package, to no avail.

I am sure that it is something very minor where I went wrong, and in all likelihood the problem is on my side. I just cannot figure out what it might be.


> sessionInfo()
R version 3.4.1 (2017-06-30)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows 7 x64 (build 7601) Service Pack 1

Matrix products: default

[1] LC_COLLATE=German_Germany.1252  LC_CTYPE=German_Germany.1252   
[3] LC_MONETARY=German_Germany.1252 LC_NUMERIC=C                   
[5] LC_TIME=German_Germany.1252    

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
[1] _0.1.0 

loaded via a namespace (and not attached):
[1] compiler_3.4.1 tools_3.4.1  

* using log directory '/cygdrive/d/Home/projects/R_package_dev/helpers2.Rcheck'
* using R version 3.4.0 (2017-04-21)
* using platform: x86_64-unknown-cygwin (64-bit)
* using session charset: ISO8859-1
* checking for file 'helpers2/DESCRIPTION' ... OK
* checking extension type ... Package
* this is package 'helpers2' version '0.1.0'
* package encoding: UTF-8
* checking package namespace information ... OK
* checking package dependencies ... OK
* checking if this is a source package ... OK
* checking if there is a namespace ... OK
* checking for executable files ... OK
* checking for hidden files and directories ... OK
* checking for portable file names ... OK
* checking for sufficient/correct file permissions ... OK
* checking whether package 'helpers2' can be installed ... OK
* checking installed package size ... OK
* checking package directory ... OK
* checking DESCRIPTION meta-information ... WARNING
Non-standard license specification:
Standardizable: FALSE
* checking top-level files ... OK
* checking for left-over files ... OK
* checking index information ... OK
* checking package subdirectories ... OK
* checking R files for non-ASCII characters ... OK
* checking R files for syntax errors ... OK
* checking whether the package can be loaded ... OK
* checking whether the package can be loaded with stated dependencies ... OK
* checking whether the package can be unloaded cleanly ... OK
* checking whether the namespace can be loaded with stated dependencies ... OK
* checking whether the namespace can be unloaded cleanly ... OK
* checking loading without being on the library search path ... OK
* checking dependencies in R code ... OK
* checking S3 generic/method consistency ... OK
* checking replacement functions ... OK
* checking foreign function calls ... OK
* checking R code for possible problems ... OK
* checking Rd files ... OK
* checking Rd metadata ... OK
* checking Rd cross-references ... OK
* checking for missing documentation entries ... OK
* checking for code/documentation mismatches ... OK
* checking Rd \usage sections ... OK
* checking Rd contents ... OK
* checking for unstated dependencies in examples ... OK
* checking examples ... NONE
* checking PDF version of manual ... WARNING
LaTeX errors when creating PDF version.
This typically indicates Rd problems.
* checking PDF version of manual without hyperrefs or index ... ERROR
Status: 1 ERROR, 2 WARNINGs

-----Ursprüngliche Nachricht-----
Von: Dirk Eddelbuettel [mailto:dirk.eddelbuettel at gmail.com] Im Auftrag von Dirk Eddelbuettel
Gesendet: Donnerstag, 10. August 2017 14:32
An: Duncan Murdoch
Cc: Käthner, David; r-package-devel at r-project.org
Betreff: Re: [R-pkg-devel] The Help (e.g. links) is not working for my packages

On 9 August 2017 at 08:38, Duncan Murdoch wrote:
| Nothing that you've written is reproducible by others.  See if you can 
| put together a short self-contained series of instructions that 
| display the problems (or just one of them).  It might involve 
| installing from Github, or making a package tarball available somewhere.

I am fairly certain I have observed this myself, and I *think* it simply stems from running R CMD INSTALL (and alike) from a source directory, as opposed to a tarball.  I filed it under minor nuisance and didn't care too much either as the official two-step of 'R CMD build ...; R CMD INSTALL ...'
is just that: the official and recommended way. With which things work.


http://dirk.eddelbuettel.com | @eddelbuettel | edd at debian.org

More information about the R-package-devel mailing list