[R] startup loading issue

ken eagle e@g|ek2011 @end|ng |rom gm@||@com
Tue Oct 25 15:33:10 CEST 2022

I thought I was loading a ~300M binary (bigwig) file into another
application, but the window changed to the R GUI without my realizing it
and R tried to load the file.  I’m on a Mac M1-based laptop with system
12.5.1 and 8G of ram, running R 4.2.1 (Intel version).   According to
ActivityMonitor, R grabs ~45G (!) of memory before the system warns me that
it is out of application memory and I have to force quit R.  I have since
tried locating/moving/editing .Rprofile, .Rapp.history, or .RData files
with no impact.  Starting R from a Terminal session works fine but has no
impact on the problem.  I have tried restarting R, restarting the laptop,
and re-installing R, all with no change; on restarting R, it just starts
reloading the file it can’t handle (CtrlC and ESC don’t do anything). I
have changed the directory name of the offending file, and the filename
itself, without changing what happens upon starting R.  I’ve also created a
new .Rprofile that successfully executes but does not prevent the load
problem unless the .Rprofile includes a quit() command.

Any suggestions?


	[[alternative HTML version deleted]]

More information about the R-help mailing list