[R] Installing dyplr on Linux requires a ton of chasing down dependencies

Jeff Newmiller jdnewm|| @end|ng |rom dcn@d@v|@@c@@u@
Mon Oct 14 10:25:34 CEST 2019


On October 12, 2019 1:46:29 PM PDT, Adam Frank <phil.math.logic using gmail.com> wrote:
>I just got a new Linux computer running Pop!_OS.  If I download R from
>repository, which is basically he same as on Ubuntu, I get an outdated
>version that can't run ggplot2.  So I went to the R download page and
>downloaded the newest version.  It has make and config files but they
>require an intense number of dependencies and I couldn't figure out how
>ever get the X11 dependency resolved.  Some places suggested installing
>packages related to xorg, but I didn't find `xorg-x11*` in my package
>manager at all.  I tried installing `xorg-*` but this didn't resolve
>I tried installing Anaconda and doing everything within there.  It
>the latest version of R but still to run `install.packages("dplyr",
>dependencies=T)` throws a ton of errors about unmet dependencies, one
>which is again X11.  So at this point I'm feeling kind of stuck on this
>And it just seems wild to me that it's this hard to get R working with
>dplyr.  Is there an easier way?
>I also tried guessing that maybe `conda install r-dplyr` might do
>but no luck, package not found.  Might have something to do with
>environments, I'm not really clear on how those work.
>Anyway, for details: My OS is Pop!_OS 19.04, my R version is 3.6.1,
>1.1.456 running by way of Anaconda.  Recently ran an update on every R
>	[[alternative HTML version deleted]]
>R-help using r-project.org mailing list -- To UNSUBSCRIBE and more, see
>PLEASE do read the posting guide
>and provide commented, minimal, self-contained, reproducible code.

Sent from my phone. Please excuse my brevity.

More information about the R-help mailing list