[R] Installing dyplr on Linux requires a ton of chasing down dependencies

Adam Frank ph||@m@th@|og|c @end|ng |rom gm@||@com
Sat Oct 12 22:46:29 CEST 2019

I just got a new Linux computer running Pop!_OS.  If I download R from the
repository, which is basically he same as on Ubuntu, I get an outdated
version that can't run ggplot2.  So I went to the R download page and
downloaded the newest version.  It has make and config files but they
require an intense number of dependencies and I couldn't figure out how to
ever get the X11 dependency resolved.  Some places suggested installing
packages related to xorg, but I didn't find `xorg-x11*` in my package
manager at all.  I tried installing `xorg-*` but this didn't resolve the

I tried installing Anaconda and doing everything within there.  It delivers
the latest version of R but still to run `install.packages("dplyr",
dependencies=T)` throws a ton of errors about unmet dependencies, one of
which is again X11.  So at this point I'm feeling kind of stuck on this ...

And it just seems wild to me that it's this hard to get R working with
dplyr.  Is there an easier way?

I also tried guessing that maybe `conda install r-dplyr` might do something
but no luck, package not found.  Might have something to do with
environments, I'm not really clear on how those work.

Anyway, for details: My OS is Pop!_OS 19.04, my R version is 3.6.1, RStudio
1.1.456 running by way of Anaconda.  Recently ran an update on every R

	[[alternative HTML version deleted]]

More information about the R-help mailing list