[R] Unable to run RcmdrPlugin.survival using 3.2.2 with Windows 10

Joyaa Antares joyaa at goldcoastosteopathy.com.au
Fri Sep 4 03:36:44 CEST 2015

Dear John, Dear List,

Thank you for responding.  Like you, I have tried uninstalling R and 
reinstalling again.  Question 1: having uninstalled R, how do you delete the 
package library?

I have used defaults throughout the process, except for running the whole 
things as Administrator rather than a User.  For the mirror, my first two 
install attempts were via a mirror in Germany.  My 3rd and 4th attempts via 
Cambridge, UK.

Perhaps importantly: the first time I ran the RcmdrPlugin.survival plug-in 
it worked fine.  I got half way through the exercise I was attempting, then 
closed the programs for the night.  The next day, when I tried to reload the 
plugin from R Commander, the plugin asked me to restart R Commander, but on 
opting for "Yes", this is when R Commander does not open properly.

My thanks to you and the list for your time.  Joyaa (Gold Coast, Queensland, 

-----Original Message----- 
From: Fox, John
Sent: Friday, September 4, 2015 1:29 AM
To: Joyaa Antares
Cc: r-help at r-project.org
Subject: RE: [R] Unable to run RcmdrPlugin.survival using 3.2.2 with Windows 

Dear Joyaa,

I too run R 3.2.2 on a Windows 10 system. I uninstalled R, deleted my 
package library, and then reinstalled R and the Rcmdr and 
RcmdrPlugin.survival packages. I took all defaults, except that I selected 
the SDI rather than the default MDI for Rgui, but I seriously doubt that 
this is the source of your problem. I used the 0-Cloud mirror, both for R 
3.2.2 and for packages.

I'm afraid that I can't duplicate your problem -- everything works perfectly 
fine for me.

You provided a reasonable amount of detail, but is there anything else you 
can add?


John Fox, Professor
McMaster University
Hamilton, Ontario
Canada L8S 4M4
web: socserv.mcmaster.ca/jfox

From: R-help [r-help-bounces at r-project.org] on behalf of Joyaa Antares 
[joyaa at goldcoastosteopathy.com.au]
Sent: September 3, 2015 8:31 AM
To: r-help at r-project.org
Subject: [R] Unable to run RcmdrPlugin.survival using 3.2.2 with Windows 10

Hello r-help,

I am quite new to R.  I downloaded R 3.2.2 for Windows to use with Windows 

On attempting to load the RcmdrPlugin.survival plug-in I got this error 

Error in structure(.External(.C_dotTclObjv, objv), class = "tclObj") :
  [tcl] invalid command name "configure".

The lead-up to this was:

* I uninstalled R 3.2.2 and deleted all R files I could find.
* Downloaded R 3.2.2 to do a fresh install
* Opened the .exe file as Administrator
* Ran 64-bit R as Administrator
* Updated all packages
* Installed Rcmdr and RcmdrPlugin.survival
* Ran Rcmdr using library(Rcmdr) from the console
* This required an install of a host of packages, which I installed
* Loaded RcmdrPlugin.survival from the Tools menu
* I was asked to restart R commander, and when I tried it didn’t open 
properly (showing only File/Edit/Data in the menu bar), and this wouldn’t 
close properly either.  The error message as above showed in the console.

I haven’t posted to the list before and would be very grateful for help. 
Thank you.   Joyaa
        [[alternative HTML version deleted]]

R-help at r-project.org mailing list -- To UNSUBSCRIBE and more, see
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.

More information about the R-help mailing list