[R] Latest version of Rtools is incompatible with latest version of R !!

Henrik Bengtsson hb at biostat.ucsf.edu
Thu Jan 15 20:53:06 CET 2015

On Thu, Jan 15, 2015 at 9:27 AM, PRAMEET LAHIRI
<prameet_lahiri at yahoo.co.in> wrote:
>  I have installed R version 3.1.2.  I tried to install RTools32.exe which is the latest version (using this link - http://cran.r-project.org/bin/windows/Rtools/) ! However on using the function find_rtools() an error message was displayed which said ---
> "Rtools is required to build R packages, but no version of Rtools compatible with R 3.1.2 was found. (Only the following incompatible version(s) of Rtools were found:3.2)Please download and install Rtools 3.1 from http://cran.r-project.org/bin/windows/Rtools/ and then run find_rtools()."
> I want to know why the latest version of R is not supporting the latest Rtools! Any suggestions?

find_rtools() is a function of the 'devtools' package.  Maybe it's an
issue with that package and not R, and I'm pretty sure Duncan Murdoch
put great efforts in asserting Rtools is working well with R (that's
been my experience for the last 5-10 years).

I also know that devtools 1.7.0 have been submitted to CRAN, so
if/when that becomes available you problem might be solved.  You can
of course also grab it earlier from the devtools GitHub page.

My $.02


> Thanks for your time,Prameet
>         [[alternative HTML version deleted]]
> ______________________________________________
> R-help at r-project.org mailing list -- To UNSUBSCRIBE and more, see
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.

More information about the R-help mailing list