[R] Suggestions for workaround for R Markdown problem with data() ?

Yihui Xie xie at yihui.name
Mon Jan 12 17:41:10 CET 2015

Can you try to compile your .Rmd file in the R console (instead of
clicking the button in RStudio)?


If it gives the same error, please post the traceback() information. I
just tried the following minimal example, and I was unable to
reproduce your problem. You may also try to reinstall the package:

output: pdf_document


Yihui Xie <xieyihui at gmail.com>
Web: http://yihui.name

On Mon, Jan 12, 2015 at 12:06 AM, Molly Elliott
<elliotmo at onid.oregonstate.edu> wrote:
> R version: 3.1.2 (2014-10-31)
> RStudio version: 0.98.1091
> MacOS X Yosemite v. 10.10.1
> When I run the following in the console, all is well:
> data(IlluminaHumanMethylation450kanno.ilmn12.hg19)
> Yet, when I compile in my .Rmd file, in RStudio (knit to PDF), I get the following error:
> Error in file(file, "rt") : cannot open the connection
> Calls: <Anonymous> ... withVisible -> eval -> eval -> read.delim -> read.table -> file
> Execution halted
> From what I have read, this could be alleviated by pointing the the source file for data(IlluminaHumanMethylation450kanno.ilmn12.hg19) as opposed to LazyLoading with the data() function.  Yet, I’m not sure how to work around this. (This is my first R project ever) The data(IlluminaHumanMethylation450kanno.ilmn12.hg19) is just loading an annotation file from library(IlluminaHumanMethylation450kanno.ilmn12.hg19), and I’m not sure of the file type the data are stored under (.txt, .csv, etc).
> Thanks in advance!
> Molly

More information about the R-help mailing list