[R] tcltk makes R crash under Mavericks

John Fox jfox at mcmaster.ca
Mon Jan 13 20:59:44 CET 2014

Dear Claudia,

The R Commander installation notes at <http://socserv.socsci.mcmaster.ca/jfox/Misc/Rcmdr/installation-notes.html> have some information (near the bottom) about trouble-shooting tcltk problems on Mac OS X. Maybe they will help.


John Fox
McMaster University
Hamilton, Ontario, Canada
On Mon, 13 Jan 2014 11:30:41 -0700
 Claudia Tebaldi <claudia.tebaldi at gmail.com> wrote:
> Hello
> I was just forced to upgrade my OS X to Mavericks. Everything seemed to be
> OK, R still worked seemingly fine within emacs (am using the latest
> version, R 3.0.2, and the latest version of ESS, with Emacs 24.3.1) until I
> tried loading the library extRemes. Apparently the call within that library
> to load tcltk was the culprit. In fact R crashes simply by trying to load
> the latter (without trying loading extRemes). I tried reinstalling
> everything (R and the packages, and the tools' tcltk package -- even if I
> think it should be bundled with R by default). R keeps crashing with a
> simple "R process terminated" message.
> Everything worked just swimmingly under Snow Leopard. Sigh.
> Can anybody please help?
> Thank you
> Claudia
> Claudia Tebaldi
> Project Scientist,
> and Science Fellow
> Climate Central
> (303) 497 1710 w
> (303) 775 5365 c
> 	[[alternative HTML version deleted]]
> ______________________________________________
> R-help at r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.

More information about the R-help mailing list