[R] Can't event start 'rattle' under Ubuntu 64bit

Kamil Sijko kamil.sijko at gmail.com
Fri Sep 10 17:36:44 CEST 2010

Dear all,

I've wanted to give a try to the rattle GUI for R. After long struggle
with dependencies I've finally managed to install rattle and all of
its dependencies, although for some of them I've been forced to use
cran2deb. And now all I get is:

> library(rattle)
Loading required package: pmml
Loading required package: XML
Loading required package: RGtk2
Loading required package: colorspace
Rattle: Graphical interface for data mining using R.
Version 2.5.39 Copyright (c) 2006-2010 Togaware Pty Ltd.
Type 'rattle()' to shake, rattle, and roll your data.
> rattle()
Error: attempt to apply non-function
In addition: Warning message:
In method(obj, ...) : Invalid object type `GtkFrame'
Rattle timestamp (for the error above): 2010-09-10 17:24:14

As an addition a blank window appears. And I'm stuck. Can anyone -
please - point me in the right direction?


More information about the R-help mailing list