[R] New version

Duncan Murdoch murdoch.duncan at gmail.com
Tue Oct 5 15:11:28 CEST 2010

  On 05/10/2010 9:00 AM, ogbos okike wrote:
> Hello,
> The R version on my  system is R version 2.8.1 (2008-12-22).  I have
> previously installed all the desired packages  for my work - and they have
> been working fine. However, somebody played with my system and removed
> almost all the stuff. I am installing the packages again.
> But I am finding some packages (such as, sp, rgdal, raster, etc) hard to
> install. Some of the error messages indicate that 2.8.1 is old and that the
> package requires 2.10.0.
> I have tried to upgrade to 2.10.0 or to the newest release but without luck.
> I am now considering reinstalling R ( and then reinstall all the removed
> packages).
> Could you please advise if  this has any negative implications the R package
> or if I have any better option as to handle this problem?

I would install the current release of R.  Version 2.8.1 is quite old, 
and likely nobody will support you on it.

You can get old copies of packages from the CRAN archives 
<http://cran.r-project.org/src/contrib/Archive/> if you do decide to 
stick with an obsolete version, but I don't know a simple way to find 
the best combination of package versions for 2.8.1.

Duncan Murdoch

More information about the R-help mailing list