[R] write.csv size limit in R 2.11.0 -- crashes

N Klepeis lists1 at exposurescience.org
Wed Apr 28 00:58:52 CEST 2010

The latest patched build 51822 fixed the write.csv problem:  

On 4/26/2010 2:10 PM, Duncan Murdoch wrote:
> On 26/04/2010 4:25 PM, N Klepeis wrote:
>> Hi,
>> I just installed R 2.11.0 Win32 and tried to use write.csv (or 
>> write.table) to write a 121000x26 data frame. This crashes R.
>> The dataframe was written OK in R 2.10.1.
>> I tried up to 108000 rows and the file was written OK.  But then 
>> going to 109000 causes the crash.
>> Anyone else see this?   I'll gather some more info before reporting a 
>> bug.
> Please try R 2.11.0 patched.  There was a problem in the date/time 
> formatting routines which I fixed a few days ago in revision 51811 
> that could be involved here.  (You may need to wait a few days:
> CRAN is offline, and the mirrors I checked hadn't updated to this 
> version yet.)
> You could also try an R-devel build; it never had the bug.
> Duncan Murdoch
> P.S. Bug discussions are generally better in R-devel rather than R-help

More information about the R-help mailing list