[R] [SPAM] Re: Error in library(gplots) : there is no package called 'gplots'

Martin Valere valere.martin at vogelwarte.ch
Fri Apr 16 12:13:16 CEST 2010

Dear James,

  i have tried to install the package RODBC1-3.1 with R version 2.9.0 and 2.10.1 (using Opensuse 11.1, 64bits). I have tried install.packages locally (package downloaded and stored locally on the computer) or directly from Internet (using different mirrors !). Same results each time ...

Same outcome either if I try to install other packages like for instance e1071. So it appears this is not linked to the package itself but rather with R-base or R-devel (both are installed) ...



-----Ursprüngliche Nachricht-----
Von: james [mailto:james at ipec.co.uk]
Gesendet: Freitag, 16. April 2010 10:47
An: Martin Valere
Cc: R Help List
Betreff: [SPAM] Re: [R] Error in library(gplots) : there is no package
called 'gplots'
Wichtigkeit: Niedrig

Hi Vava,
What version of R are you using? I'm not sure but I think that R will 
refuse to install a package in this way if the version of gplots is 
incompatiable with the version of R you're using. You can check the 
depends of packages on CRAN.


Vava wrote:
> Thanks for your suggestion Tal. Unfortunately, still no luck with me ...
> still get the usual error message:
> " Error in library(gplots) : there is no package called 'gplots' ", whatever
> I try to install.
> This is a mystery to me with respect to why /how. I am really stuck with
> that problem.
> Best, 
> Valère

 -----Ursprüngliche Nachricht-----
Von: 	Martin Valere  
Gesendet:	Donnerstag, 25. März 2010 10:58
An:	'r-help at R-project.org'
Betreff:	Error in library(gplots) : there is no package called 'gplots'

Dear all,

   I have an issue trying to install new packages (have tried with RODBC_1.3-1, gplots_2.6.1, gtools_2.7.4 packages) and get the same error message :
"Error in library(gplots) : there is no package called 'gplots'"

Only clue I have found so far on the Web is related to Perl (Perl modules are installed on my computer, but which one is related to gplots if any ?); no gplots in usr/lib or /usr/lib64 at least ... I am somewhat lost here, having no idea about Perl (if Perl is really the issue ?).

I am using OpenSuse 11.1 (64bits); and R version 2.9.0. Installation of package  is performed offline as Root.


Valère, Switzerland

More information about the R-help mailing list