[R] Trying to install rjags on Mac OS X 10.5 -- problem solved

Lindsay Stirton Lindsay.Stirton at manchester.ac.uk
Wed Jan 2 20:54:43 CET 2008

Dear R Users,

Thanks to the suggestions of a few of you, I have solved the problems I 
have had
getting rjags running on Mac OS X 10.5. In the hope that others in 
future might
benefit, I set out here how the problem was solved.

1. The problem of gfortran not installing properly was fixed as per 
this post -
http://tolstoy.newcastle.edu.au/R/e3/devel/07/12/0581.html. Accordingly, the
following fix allowed it to install properly

sudo rm /usr/local/lib
sudo mv '/usr/local/lib 1' /usr/local/lib

2. Vincent Nijs suggested I add the following to .bashrc.

export LD_LIBRARY_PATH="/usr/local/lib"
export PKG_CONFIG_PATH="/usr/local/lib/pkgconfig"

I cannot say whether this was necessary or not; it was not sufficient.

3. Finally, thanks to Rob Goedman, I did a clean install of pkg-config,
compiling it myself. I had previously used Macport to install a port of
pkg-config, and R for some reason didn't seam to like this.

After that, sudo R CMD INSTALL rjags_1.0.1-1.tar.gz worked fine.

Best wishes,

Lindsay Stirton

More information about the R-help mailing list