[R] Installing packages with R v.2.3.1 on MAC OS X -- Error: "Cannot chdir: No such file or directory"

Snaebjorn Gunnsteinsson sgunnste at jhsph.edu
Thu Sep 21 18:16:58 CEST 2006

Dear all,

    I'm working on MAC OS X 10.4.7 using R version 2.3.1 (June 2006)  
and platform powerpc-apple-darwin8.6.0. Since I installed the new  
version of R I cannot install packages any more (but it worked fine  
before) and get the following message every time. I can, however,  
install packages from the command line if I get them as precompiled  

 > install.packages("foreign", lib="~/libs/Rlibs")
trying URL 'http://www.biometrics.mtu.edu/CRAN/bin/macosx/powerpc/ 
Content type 'application/x-gzip' length 268096 bytes
opened URL
downloaded 261Kb

tar: ~/libs/Rlibs/file77a4044d: Cannot chdir: No such file or directory
tar: Error is not recoverable: exiting now

gzip: stdout: Broken pipe
Error in sprintf(gettext(fmt, domain = domain), ...) :
         argument is missing, with no default

The command did create the directory (i.e. ~/libs/Rlibs/file77a4044d)  
on my system and has open priviledges (i.e. drwxr-xr-x) but is empty.  
I've tried 'sudo R' but that does not help and cannot find anything  
helpful on this in the R-help archives or FAQ.

Thanks in advance for your help,
I would really appreciate any help in solving this,
best regards,

More information about the R-help mailing list