[R] JGR on SUSE 10.1 AMD 64

Tomas Willebrand tomas.willebrand at szooek.slu.se
Sun Sep 10 18:51:51 CEST 2006

Prof Ripley and Rainer;

Thanks for the help. 

I changed the file "/usr/lib64/R/etc/ldpaths" so that the first line looked 


and then everything worked OK!

But when I tested a fresh install of the R-base*rpm and changed the ldpaths 
file before attempting to install JGR it did not install properly!! Not the 
same error as previously when iplots was suppose to load! (ldpaths identical 
in both cases)

-- Install R-base -> failed installation of rJava -> edit ldpaths -> reinstall 
rJava,iplots, JGR -> SUCCESS

-- Install R-base -> edit ldpaths -> loading rJava fails after compiling  
-> ????

Not sure what is going on and do not need to know! 
But maybe someone would find this note useful.

Thanks again


söndag 10 september 2006 14:02 skrev Rainer Volz:
> Prof Brian Ripley <ripley <at> stats.ox.ac.uk> writes:
> > This is something that is set up when R is configured, and stored in
> > R_HOME/etc/ldpaths.  Has perchance your Java subsystem been updated since
> > R was installed?
> True.
> > In which case update R_HOME/etc/ldpaths as appropriate,
> > or set R_JAVA_LD_LIBRARY_PATH (not LD_LIBRARY_PATH) to override the
> > setting there.
> That's much better. Thank you.
> ______________________________________________
> R-help at stat.math.ethz.ch mailing list
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide
> http://www.R-project.org/posting-guide.html and provide commented, minimal,
> self-contained, reproducible code.

+46 70 288 02 03

More information about the R-help mailing list