[R] R-1.9.1 compiling problem

lu kan luk111111 at yahoo.com
Mon Oct 11 17:10:32 CEST 2004

Hi Peter,

Thanks for your help. 

But the installation file "INSTALL" comes with
The following is a copy of it.



This document concerns building and installing R from
sources.  Pre-made
binaries are made available for some systems with
varying regularity and
can be obtained from CRAN (see the RESOURCES file).

For building on Windows 9x/ME/NT/2000 see the file

The main source of information on installation is the
`R Installation
and Administration Manual', an HTML copy of which is
available as file
`doc/html/R-admin.html'.  Please read that before
installing R.  But
if you are impatient, read on but please refer to the
manual to
resolve any problems.


As you are reading this file, you have unpacked the R
sources and are
presumably in the top directory.  Issue the following


(If your make is not called `make', set the
environment variable MAKE to
its name, and use that name throughout these
This will take a while, giving you time to read

Then check the built system worked correctly, by

	make check

and make the manuals by (as many options as preferred

	make dvi	to create DVI versions
	make pdf	to create PDF versions
	make info	to create info files


You do not need to install R to run it: you can run R
by the script
`bin/R' which you can link or copy to any convenient
place in your path.

For a site-wide installation, use

	make install
	make install-dvi
	make install-info
	make install-pdf

choosing to install the manuals that you made.

This installs to the default location (typically
`/usr/local') for your
platform: see the Installation and Administration
Manual for other options.

--- Peter Dalgaard <p.dalgaard at biostat.ku.dk> wrote:

> lu kan <luk111111 at yahoo.com> writes:
> > I downloaded R-1.9.1.tgz, and tried to install it
> on
> > debian linux machine according to the installation
> > commands
> > ./configure
> > make
> > 
> > but I got the following error message. Could you
> > please advise me what is the reason for this. 
> > `/home1/lu/usr/tmp1/R-1.9.1/src/scripts'
> > 
> >     The current directory must be set to the RSI
> > directory.
> >     Change the default to the RSI directory and
> re-run
> >     this script.
> I think it means that you're picking up the wrong
> version of the
> "install" script. That exact phrasing occurs in
> (thank Google!)
> #!/bin/sh 
> #
> #       $Id: install,v 1.67 2003/01/28 19:54:23 beth
> Exp $
> #
> # install
> #
> # Research Systems, Inc                        
> March 1, 1988
> # This shell script carries out the steps required
> to install IDL
> # or an IDL based product once the main directory
> has been unpacked.
> # It expects to be run from the RSI directory.
> #
> ...
> Does that ring a bell with you?
> -- 
>    O__  ---- Peter Dalgaard             Blegdamsvej
> 3  
>   c/ /'_ --- Dept. of Biostatistics     2200 Cph. N 
>  (*) \(*) -- University of Copenhagen   Denmark     
> Ph: (+45) 35327918
> ~~~~~~~~~~ - (p.dalgaard at biostat.ku.dk)            
> FAX: (+45) 35327907


Declare Yourself - Register online to vote today!

More information about the R-help mailing list