[R] R-1.9.1 on OS 10.2

Prof Brian Ripley ripley at stats.ox.ac.uk
Wed Oct 6 12:50:57 CEST 2004

On Wed, 6 Oct 2004 K.M.Csillery at sms.ed.ac.uk wrote:

> I've been using R 1.7.1 but now I need to upgrade to R-1.9.1.
> Since it is not on the Fink tree yet 

What is `it'?   The current version of R is 2.0.0, BTW.

> I tried to install it from source to
> my sw library. The configuration runs fine, but make doesn't.
> Here is the error message I get:
> /sw/lib/libg2c.a(err.o) definition of common f(short, void, int, char)
> (size 4)
> /usr/bin/libtool: internal link edit command failed
> make[4]: *** [libRlapack.dylib] Error 1
> make[3]: *** [R] Error 2
> make[2]: *** [R] Error 1
> make[1]: *** [R] Error 1
> make: *** [R] Error 1

Do read what R-admin.html says (as INSTALL asks you to):

tar zxvf R-1.9.1.tgz
cd R-1.9.1
./configure --with-blas='-framework vecLib' --with-lapack --with-aqua 
The first two options are strongly recommended. 

Now you know why!  Your compiler has a libg2c that is not shared and so 
cannot be used in a dynamic library.  Please do follow the strong 

> Ok, than I tried to use the binaries for OS, but I get an installation
> error.

PLEASE do read the posting guide and give useful information: this is 
almost maximally uniformative.

> So, again, my machine is OS 10.2.8, and I use emacs and ESS under X11 and
> R-1.7.1 just workes fine (installed from Fink tree after release).
> Any suggestions are welcome!
> Katalin
> PS Sorry, but I might have double posted the message.

You did.  I suspect you have not read the MacOS FAQ either, which probably 
will resolve your issues with the binary distribution.

Brian D. Ripley,                  ripley at stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272866 (PA)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

More information about the R-help mailing list