a question on plot(), workspace or method dispatch, NOT about: Re: [R] RWinEdt, other text editors and R2.01 a problem in pasting commands

Uwe Ligges ligges at statistik.uni-dortmund.de
Mon Nov 22 18:54:43 CET 2004

giovanna jona lasinio wrote:

> Dear All,
> In the last few days I started using the last version of R as I
> encountered a problem with R1.9 and the use of RWinEdt, however the
> problem shows with R2.01 as well. More precisely
> 1. I install R2.01 after removing old verions of R
> 2. I Install RWinEdt package versione RWinEdt_1.6-2 and
> SWinRegistry_0.3-2 and everything seems fine
> 3. I recall the RWinEdt library (library(RWinEdt)) and WinEdt appears
> 4. now after loading a workspace I run the following command using the
> paste icon in WinEdt: 
> plot(x,xaxt="n",xlab="time", ylab=expression(alpha),main=nome,type="l")
> And I get the following error message:
> <<Error in stripchart(x, ...) : unused argument(s) (xaxt ...)>>
>>From now on the plot command stops working, it doesn't recognize any
> option not even type="l" or type="b" or anything.
> If I type the intrusction directly on the command window without any
> previous paste operation from WinEdt the command works properly.
> Furthermore if I try to paste commands by simply coping it from a text
> file and pasting it on the R command window I have the same problem. I
> even tried:
> source("prova.txt") containing the same command line and I got the same
> error:
> Error in stripchart(x, ...) : unused argument(s) (xaxt ...)
> I'm not very good at using Windows XP, can anyone help?
> Thanks
> Giovanna Jona Lasinio

Please don't complain about R-WinEdt, WinEdt, other editors, or Windows 
if the point is obviously somewhere else!

1. Have you redefined plot() in your workspace?
2. What kind of object is x (in particular it's class, please!)?

Uwe Ligges

More information about the R-help mailing list