[R] RWinEdt, other text editors and R2.01 a problem in pasting commands

giovanna jona lasinio giovanna.jonalasinio at uniroma1.it
Mon Nov 22 12:43:04 CET 2004

Dear All,
In the last few days I started using the last version of R as I
encountered a problem with R1.9 and the use of RWinEdt, however the
problem shows with R2.01 as well. More precisely

1. I install R2.01 after removing old verions of R
2. I Install RWinEdt package versione RWinEdt_1.6-2 and
SWinRegistry_0.3-2 and everything seems fine
3. I recall the RWinEdt library (library(RWinEdt)) and WinEdt appears
4. now after loading a workspace I run the following command using the
paste icon in WinEdt: 
plot(x,xaxt="n",xlab="time", ylab=expression(alpha),main=nome,type="l")

And I get the following error message:
<<Error in stripchart(x, ...) : unused argument(s) (xaxt ...)>>
>From now on the plot command stops working, it doesn't recognize any
option not even type="l" or type="b" or anything.

If I type the intrusction directly on the command window without any
previous paste operation from WinEdt the command works properly.

Furthermore if I try to paste commands by simply coping it from a text
file and pasting it on the R command window I have the same problem. I
even tried:
source("prova.txt") containing the same command line and I got the same
Error in stripchart(x, ...) : unused argument(s) (xaxt ...)

I'm not very good at using Windows XP, can anyone help?

Giovanna Jona Lasinio

More information about the R-help mailing list