[R] R 1.9.1 compilation error (on AIX 5.1)

Prof Brian Ripley ripley at stats.ox.ac.uk
Wed Jun 23 11:11:01 CEST 2004

We do have alpha/beta test periods for new releases of R, so would anyone 
who did test AIX please confirm that they did succeed.  (No one reported 
an error, including yourself: are any AIX users interested in helping 
having R available for AIX?)   It is much better to have such reports 
during alpha test, or at least beta test.

On Wed, 23 Jun 2004, Frankie Cheung wrote:

> Dear Sir/Madam,
> I encounter some problem duuring compilation of R 1.9.1 on AIX 5.1, after
> running "./configure" then I type "make" to compile:
> # make
> .....
> gcc -I../../src/extra/zlib -I../../src/extra/bzip2 -I../../src/extra/pcre
> -I. -I../../src/include -I../../src/include -I/usr/local/include
> -DHAVE_CONFIG_H -mno-fp-in-toc  -g -O2 -c registration.c -o registration.o
> g77   -g -O2 -c xxxpr.f -o xxxpr.o
> gcc -Wl,-bdynamic -Wl,-bE:../../etc/R.exp -Wl,-bM:SRE -L/usr/local/lib -o
> R.bin  CConverters.o Rdynload.o RNG.o apply.o arithmetic.o apse.o array.o
> attrib.o base.o bind.o builtin.o character.o coerce.o colors.o complex.o
> connections.o context.o cov.o cum.o dcf.o datetime.o debug.o devPS.o
> devPicTeX.o deparse.o deriv.o devices.o dotcode.o dounzip.o dstruct.o
> duplicate.o engine.o envir.o errors.o eval.o format.o fourier.o gram.o
> gram-ex.o graphics.o identical.o internet.o iosupport.o lapack.o list.o
> logic.o main.o mapply.o match.o memory.o model.o names.o objects.o optim.o
> optimize.o options.o par.o paste.o pcre.o platform.o plot.o plot3d.o
> plotmath.o print.o printarray.o printvector.o printutils.o qsort.o
> random.o regex.o relop.o saveload.o scan.o seq.o serialize.o size.o sort.o
> source.o split.o sprintf.o subassign.o subscript.o subset.o summary.o
> unique.o util.o version.o vfonts.o registration.o xxxpr.o
> ../unix/libunix.a ../appl/libappl.a ../nmath/libnmath.a   -L/usr/local/lib
> -L/usr/local/lib/gcc-lib/powerpc-ibm-aix5.1.0.0/3.3.3
> -L/usr/local/lib/gcc-lib/powerpc-ibm-aix5.1.0.0/3.3.3/../../../../powerpc-ibm-aix5.1.0.0/lib
> -L/usr/local/lib/gcc-lib/powerpc-ibm-aix5.1.0.0/3.3.3/../../.. -lfrtbegin
> -lg2c -lm -lgcc_s
> /usr/local/lib/gcc-lib/powerpc-ibm-aix5.1.0.0/3.3.3/libgcc.a -lg
> /lib/crt0.o ../extra/zlib/libz.a ../extra/bzip2/libbz2.a
> ../extra/pcre/libpcre.a -ldl -lm -lc
> /usr/local/bin/ld: target dynamic not found
> collect2: ld returned 1 exit status
> make[3]: *** [R.bin] Error 1
> make[3]: Leaving directory `/d1/ftcheung_GoIn/tmp/R-1.9.1/src/main'
> make[2]: *** [R] Error 2
> make[2]: Leaving directory `/d1/ftcheung_GoIn/tmp/R-1.9.1/src/main'
> make[1]: *** [R] Error 1
> make[1]: Leaving directory `/d1/ftcheung_GoIn/tmp/R-1.9.1/src'
> make: *** [R] Error 1
> I've tried to use AIX xlc compiler and GCC compiler (v2.95 and v3.3.3) but
> all of them result to the same error message shown above. Can anyone give
> me some hint of how to solve it?

You appear not to be using the standard loader (`/usr/local/bin/ld').  
Please set MAIN_LDFLAGS (ideally in config.site before configure, but you
can edit Makeconf now) to whatever your loader needs.  If this is GNU ld
then I guess you need -Wl,--export-dynamic.

Brian D. Ripley,                  ripley at stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272866 (PA)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

More information about the R-help mailing list