[R] R on Irix 6.5 fails when trying to load external data?

Peter Dalgaard p.dalgaard at biostat.ku.dk
Wed Dec 1 23:58:16 CET 2004

William Faulk <wfaulk at icoria.com> writes:

> I've previously installed R on Solaris and everything went fine there.
> I'm now trying to install on Irix 6.5 (about which, unfortunately, I
> have less than thorough knowledge) and it is failing.  R itself seems
> to be working okay.  Initially, Irix's dumb make program didn't
> understand some Makefile syntax in the tests, so I just ignored them
> and installed it.
> After the installation, I tried to run some demos, but when I typed
> demo(graphics), for example, it said "Error in demo(graphics) : No
> demo found for topic 'graphics'".  But when I copied-and-pasted the
> commands from doing the same thing under Solaris, everything worked
> fine.  Until I got to the commands that tried to deal with the iris
> dataset, to which it responded:
> > Error in pairs(iris[1:4], main = "Edgar Anderson's Iris Data",
> > font.main = 4,  :         Object "iris" not found
> So I started over and built gmake for Irix, hoping that the Irix make
> had done something wrong somewhere, but other than not having to tweak
> the check makefiles, nothing seems to be fixed.  Now that I can get
> the tests to run, the first test fails also due to not being able to
> load external datasets:
> > > sw <- swiss[1:5, 1:4]  # select a manageable subset
> > Error: Object "swiss" not found
> > Execution halted
> I don't know what's failing to load.  The files iris.R and swiss.R
> would seem to be in the proper locations, but, then again, neither
> Solaris nor Irix system call traces show R trying to open them at any
> point.
> I'd appreciate it if someone could give me some pointers.  It's
> important to note that I know virtually nothing about R -- I'm just a
> sysadmin asked to install R for the real users -- so treat me like an
> idiot.

Oooh, that's tempting ;-) Unfortunately, I can't spot that you've done
anything really idiotic. You did clean up and start from scratch after
building gmake, right? The best idea I can come up with is that you
might have a dud "install" command sitting somewhere and getting in
the way. I believe this has tripped IRIX users before, but I could be

   O__  ---- Peter Dalgaard             Blegdamsvej 3  
  c/ /'_ --- Dept. of Biostatistics     2200 Cph. N   
 (*) \(*) -- University of Copenhagen   Denmark      Ph: (+45) 35327918
~~~~~~~~~~ - (p.dalgaard at biostat.ku.dk)             FAX: (+45) 35327907

More information about the R-help mailing list