[R] Compilation problem SuSE 9.0

Marc Schwartz MSchwartz at medanalytics.com
Tue Nov 11 17:57:27 CET 2003

On Tue, 2003-11-11 at 10:33, Sven Sandin wrote:
> Hi
> I have problem running R (tried 1.8.0 and 1.7.1) under a fresh installed SuSE 
> 9.0 using default settings: I'm not able to send plots to the monitor. Only 
> postscript graphs are produced in external files. When assigning 
> options(device='X11') and then plotting I get the message "Error in X11() : 
> X11 is not available".
> Since this occured using the r-cran binary I tried to compile from source. 
> However, the problem was not resolved. I do not have the competence for 
> interpreting the output from the configure and make commands. Running the 
>  ./configure  (also tried  ./configure --with-x) I read the following line:
> checking for X... no
> and at the bottom:
> R is now configured for i686-pc-linux-gnu
>   Source directory:          .
>   Installation directory:    /usr/local
>   C compiler:                gcc -D__NO_MATH_INLINES -mieee-fp -g -O2
>   C++ compiler:              g++ -mieee-fp -g -O2
>   Fortran compiler:          g77 -mieee-fp -g -O2
>   Interfaces supported:
>   External libraries:        readline
>   Additional capabilities:   PNG, JPEG, bzip2, PCRE
>   Options enabled:           R profiling
>   Recommended packages:      yes
> Thankful for any help on this matter.

That error usually indicates that you do not have the X development
source code files and headers installed. You would need those in order
to compile R from source.

That typically should not be a problem with the pre-compiled binaries


Marc Schwartz

More information about the R-help mailing list