[R] R-1.2.0: gdb doesn't find functions in shared lib

Joerg Kindermann Joerg.Kindermann at gmd.de
Mon Jan 8 16:19:20 CET 2001

I'm trying to debug some C functions I've written for use with R. Until
recently debugging them with gdb was no problem. But since I switched to
R-1.2.0 (from R-1.0.1)  gdb can no longer find the entry points of my
functions. It either pretends to set break points but doesn't stop there or
it only stops at the end of the function.

R version R-1.2.0
gdb version GNU gdb 4.18
gcc version  2.95.2 
Linux version SUSE 7.0

I tried to recompile without the O2 option, but to no avail. I also tried
both R INSTALL <my_lib> and doing R SHLIB <my_file.c> and then manually loading
the .so file.

I would be glad to receive any hints

--  Dr. Joerg Kindermann                        Knowledge Discovery Team
    GMD   - German National Research Center for Information Technology -
    	       phone: +49 02241 142437 fax: +49 02241 142342
r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request at stat.math.ethz.ch

More information about the R-help mailing list