[R] foreign package

Douglas Bates bates at stat.wisc.edu
Mon Feb 28 21:17:39 CET 2000

Juergen Bock <juergen.bock at Roche.COM> writes:

> Dear R-Team
> I have installed R version 0.990 and the foreign package under Windows NT..
> Whilst lookup.xport() works as it should, read.xport() crashes reporting an
> "access error" as well for larger datasets as also for small datasets. I
> have tried the same on a single user machine (Intel Celeron 460, 256
> MB). It crashes with the same error. On computer I have also installed R
> version 0.90 under SuSE Linux. read.xport crashes reporting an R
> sementation error.
> Do you know a solution?

Is it possible that you could make available a sample SAS XPORT data
set that exhibits this behavior?  If so, please contact me privately
to arrange the transfer.

Saikat DebRoy and I were the people who wrote the foreign package but
neither of us has a whole lot of experience with SAS and we don't have
many sample data sets on which to test this package.

The problem is probably that the count of the rows in the data set is
too large by one.  Can you check the value from lookup.xport() and
compare it to the number of rows that should be in the data set?

The algorithm for determining the end of a data set in this format is
not well defined and apparently does not correspond to their
r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request at stat.math.ethz.ch

More information about the R-help mailing list