[R] Rterm and Windows 2000

Prof Brian D Ripley ripley at stats.ox.ac.uk
Wed Aug 9 07:53:47 CEST 2000

On Wed, 9 Aug 2000, Use wrote:

> I had tried the first two ("plain" Rtem and Rterm under Emacs) and none of
> them seem to work (GNU Emacs 20.5.1). Now I've tried Rterm to run in "BATCH"
> mode and it seems to work fine. I've also proved some options and with
> options as:
> Rterm --vanilla
> or
> Rterm --no-save --no-restore
> the Rterm console admits the command q() and return the system promt but it
> doesn't work for other functions.

Thanks.  That points the finger firmly at thread handling in Windows 2000
being incompatible with earlier versions, which affects interactive use and
use with --ess, but not use with a redirected input.

I am afraid there is nothing we can do about this without a Windows 2000
system and some accurate MicroSoft documentation.

Brian D. Ripley,                  ripley at stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272860 (secr)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request at stat.math.ethz.ch

More information about the R-help mailing list