[R] No R.binary in R-0.63?

Goran Brostrom gb at stat.umu.se
Sat Nov 14 14:17:31 CET 1998

I am replying to my own question (and adding some new questions):

After some debugging, I found that $(LDCMD) is set to 'fort77' (by
configure?). This is obviously wrong, and I get an error for the

fort77 -export-dynamic -o ../../bin/R.binary  etc.

saying that -export-dynamic is an illegal option. But  'make' continues.
This raises a few questions:

1. Why do 'we' want to link with  fort77?

1'. How do I most easily change the environment so that configure chooses
    the correct linker (gcc?)?

2. Why doesn't  'make' end with a fatal error, when it doesn't succeed
   to build  R.binary? This must be fatal, if anything? At least, one
   should be told in some way that something is wrong, I think. Note that
   R  compiles so fast that it is difficult to read the output on the
   screen. On my i386/450.

3. Can I  'make' with additional flags/options on, like -Wall, without
   editing all Makefiles?


On Sat, 14 Nov 1998, Goran Brostrom wrote:

> I have tried to install R-0.63 on RedHat Linux 5.2, both Sparc and i386.
> './configure' and 'make' seem to go well, but 'make install' ends with:
> make[1]: Leaving directory `/usr/local/src/R-0.63/etc'
> Installing executables ...
> /usr/bin/install: bin/R.binary: No such file or directory
> make: *** [install] Error 1
> and, indeed, I cannot find  R.binary  anywhere. Any suggestion?
> Installing earlier versions of  R  worked fine.
 Göran Broström
 Department of Statistics              tel: +46 90 786-5223
 Umeå University                       fax: +46 90 786-6614
 S-90187 Umeå, Sweden               e-mail:  gb at stat.umu.se

 http://www.stat.umu.se/~gb          ftp://capa.stat.umu.se

r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request at stat.math.ethz.ch

More information about the R-help mailing list