[Rd] R-devel no longer supports Ubuntu 14.04 LTS (insufficient PCRE version)

Prof Brian Ripley ripley at stats.ox.ac.uk
Fri Nov 20 22:39:18 CET 2015

I think you have it backwards: Ubuntu 14.04 does not support R-devel ....

PCRE 8.32 is 3 years old, so Ubuntu 14.04 shipped an already quite old 
version 19 months ago.

R has long said that its requirement was

    PCRE (version 8.10 or later, preferably 8.32 or later)

and 8.32 is indeed preferable: the aim is that all the current PCRE 
regex syntax be usable on all platforms.

Given that you appear to be installing R from the sources, PCRE is no 
more difficult to install from source ....

R-devel is 'under development' and months off release: if this proves to 
be too restrictive we can postpone the aim to 3.4.x.

On 20/11/2015 15:14, Sebastian Meyer wrote:
> Since yesterday's r69662, R no longer ./configure[s] on a standard
> Ubuntu 14.04.3 installation, which ships with PCRE 8.31
> (http://packages.ubuntu.com/trusty-updates/libpcre3-dev)
> I get:
>> checking if PCRE version >= 8.32, < 10.0 and has UTF-8 support... no
>> checking whether PCRE support suffices... configure: error: pcre library and headers are required
> Are there any workarounds for this except for manually compiling and
> installing a more recent version of PCRE from source?
> Thanks!
> 	Sebastian

Brian D. Ripley,                  ripley at stats.ox.ac.uk
Emeritus Professor of Applied Statistics, University of Oxford
1 South Parks Road, Oxford OX1 3TG, UK

More information about the R-devel mailing list