[Rd] R-devel no longer supports Ubuntu 14.04 LTS (insufficient PCRE version)

Dirk Eddelbuettel edd at debian.org
Fri Nov 20 16:49:38 CET 2015

On 20 November 2015 at 16:14, Sebastian Meyer wrote:
| Since yesterday's r69662, R no longer ./configure[s] on a standard
| Ubuntu 14.04.3 installation, which ships with PCRE 8.31
| (http://packages.ubuntu.com/trusty-updates/libpcre3-dev)
| I get:
| > checking if PCRE version >= 8.32, < 10.0 and has UTF-8 support... no
| > checking whether PCRE support suffices... configure: error: pcre library and headers are required
| Are there any workarounds for this except for manually compiling and
| installing a more recent version of PCRE from source?

The technical term is 'backport'. You could try and see if someone has taken
the (Debian or Ubuntu) source package for pcre (current, ie >= 8.32) and
created a package on launchpad.net in a PPA.

Otherwise it is pretty easy to do yourself ... and if you just wait a little
Michael will have to do it anyway to get R 3.3 built for 14.04.

(I was just bitten yesterday by R 3.2.2 re-built for Ubuntu 12.04 [ as used
by Travis ] not having libcurl capabilities. But that may well be a more
involved library than pcre so I left it at that.)


http://dirk.eddelbuettel.com | @eddelbuettel | edd at debian.org

More information about the R-devel mailing list