[Rd] GC encountered a node (…) with an unknown SEXP type

Simon Urbanek simon.urbanek at r-project.org
Thu Feb 21 02:21:11 CET 2013


please try tracking it with valgrind - that will typically trigger at the cause whereas what you see is just the fall-out much later when the memory got already corrupted.


On Feb 20, 2013, at 6:20 PM, Roger Koenker wrote:

> Dear All,
> I'm trying to track down a very erratic bug in some fortran;  I have an example that
> quite consistently segfaults on windoz, and more sporadically on mac, all in the 
> course of doing some bootstrap calculations, varying the set.seed call,  but I'm now
> trying to see what is going on on our  redhat system:
> R version 2.15.1 (2012-06-22) -- "Roasted Marshmallows"
> Copyright (C) 2012 The R Foundation for Statistical Computing
> ISBN 3-900051-07-0
> Platform: x86_64-unknown-linux-gnu (64-bit)
> I now have an example, i.e. a seed, that produces the error:
> Error in crq.fit.por(xb, yb, cb, weights = w, ctype = ctype, ...) : 
>  GC encountered a node (0xb488bc0) with an unknown SEXP type: SPECIALSXP at memory.c:927
> I've tried capturing the data for this call and running it from the terminal
> window, but annoyingly it fails to complain when I do that.  I thought someone
> might have a better idea.  My experience with gdb is very limited, I tried running
> R -d gdb  
> which reproduces the error, but this gets me back to the R prompt and I can't
> see any more than what was available without gdb.  Any advice would be most
> welcome.
> Roger
> url:    www.econ.uiuc.edu/~roger            Roger Koenker
> email    rkoenker at uiuc.edu            Department of Economics
> vox:     217-333-4558                University of Illinois
> fax:       217-244-6678                Urbana, IL 61801
> ______________________________________________
> R-devel at r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/r-devel

More information about the R-devel mailing list