[Rd] Error building R from SVN - unable to run 'pdflatex' on 'example-1.tex'

Jonathon Love jon at thon.cc
Tue Feb 5 12:55:25 CET 2013

yup. that fixed it. thanks for your help.

there are a handful of extra files in the source tarball (some pdfs, 
etc.), that aren't in the SVN. it appears that building these requires a 
bunch more stuff installed, and that's why building the source tarball 
worked, but not the SVN contents.

with thanks


> On 5 February 2013 at 01:27, Jonathon Love wrote:
> | On 04/02/13 23:47, Duncan Murdoch wrote:
> |  > Probably, but if you want help you're going to need to give some more
> |  > information first, such as what exactly you installed from SVN, what OS
> |  > you are using, what target you tried to build, and anything else
> |  > necessary so that a potential helper can duplicate what you did.
> |
> | my bad. sorry.
> |
> | on ubuntu 12.10 i did a checkout of the 2.15.2 tag
> Try this:
>     sudo apt-get build-dep r-base
> which will install what the distro itself uses to build the package.
> Also look into './configure --help' to learn about different aspects of the
> build which you can turn on or off.  I keep a little shell script with my
> prefered configuration to create a local build of r-devel from SVN.
> Dirk

More information about the R-devel mailing list