[Rd] make check fails for R.2.14.1 / SUSE Linux Enterprise Server 11 (x86_64) / intel compiler 11.1

Denis Croizé-Fillon Denis.Croize.Fillon at ifremer.fr
Fri Mar 2 14:10:56 CET 2012


On a linux (suse 11p1 64 bits) and intel compiler (11.1 20100806), for R 
2.14.1 I ran :
The config.log file is available at 

Binary file R is created, all seems Ok. However :
make check
fails with the message :
make[1]: Entering directory `/tmp/R/R-2.14.1/tests'
make[2]: Entering directory `/tmp/R/R-2.14.1/tests'
make[3]: Entering directory `/tmp/R/R-2.14.1/tests/Examples'
Testing examples for package 'base'
Error: testing 'base' failed
Execution halted
make[3]: *** [test-Examples-Base] Error 1
make[3]: Leaving directory `/tmp/R/R-2.14.1/tests/Examples'
make[2]: *** [test-Examples] Error 2
make[2]: Leaving directory `/tmp/R/R-2.14.1/tests'
make[1]: *** [test-all-basics] Error 1
make[1]: Leaving directory `/tmp/R/R-2.14.1/tests'
make: *** [check] Error 2

 From base-Ex.Rout.fail (available at base-Ex.Rout.fail), the following 
tests return FALSE and stop the execution
!identical(0, -0, num.eq=FALSE)
!identical(NaN, -NaN, single.NA=FALSE)
!identical(m, m0, attrib.as.set=FALSE)

As I'm not familiar with R, I looked for similar problems in R-devel 
archives without success.
I also tried with a previous version (2.11.1) used until now, with the 
same environment, parameters and compiler, the make check works fine

Thanks a lot for your help

Best regards,

More information about the R-devel mailing list