[Rd] matrixStats: Extend to arrays too (Was: Re: Suggestion: Adding quick rowMin and rowMax functions to base package)

Hadley Wickham hadley at rice.edu
Wed Feb 16 16:31:43 CET 2011

On Wed, Feb 16, 2011 at 2:48 PM, Tim Hesterberg <timhesterberg at gmail.com> wrote:
> For consistency with rowSums colSums rowMeans etc., the names should be
>        colMins colMaxs
>        rowMins rowMaxs
> This is also consistent with S+.

You mean rowMaxes, right?  Or is the rule to add an s, not to pluralise?

I think if you were writing a new package, you'd be better off a whole
new naming convention that extended better to higher dimensions.


Assistant Professor / Dobelman Family Junior Chair
Department of Statistics / Rice University

More information about the R-devel mailing list