[Rd] matrixStats: Extend to arrays too (Was: Re: Suggestion: Adding quick rowMin and rowMax functions to base package)

Tim Hesterberg timhesterberg at gmail.com
Wed Feb 16 15:48:39 CET 2011

For consistency with rowSums colSums rowMeans etc., the names should be
	colMins colMaxs
	rowMins rowMaxs
This is also consistent with S+.

FYI, the rowSums naming convention was chosen to avoid conflict
with rowsum (which computes column sums!).

Tim Hesterberg

>> A well-designed API generalized to work with arrays should probably
>> borrow ideas from how argument 'MARGIN' of apply() works, how argument
>> 'dim' in rowSums() for (though I must say the letter seem a bit ad hoc
>> at first sight given the name of the function). ?There may also be
>> something to learn from the 'reshape' package and so.
>I'd also recommend looking at plyr::aaply, which fixes a few things
>that have always annoyed me about apply - namely that it is not
>idempotent/identical to aperm when the summary function is the
>Assistant Professor / Dobelman Family Junior Chair
>Department of Statistics / Rice University

More information about the R-devel mailing list