[Rd] Failure to load the recommended package Matrix (Was: [R] Can one get a list of recommended packages?)

Ei-ji Nakama nakama at ki.rim.or.jp
Tue Jun 15 10:52:52 CEST 2010

I'm suffering from hay fever now...

from http://sage.math.washington.edu/home/mpatel/trac/8306/r-2.10.1.p2.log
| gcc -v
| Using built-in specs.
| Target: sparc-sun-solaris2.10
| Configured with: ../gcc-4.4.1/configure
--prefix=/usr/local/gcc-4.4.1-sun-linker/ --with-as=/usr/ccs/bin/as
| --without-gnu-as --with-ld=/usr/ccs/bin/ld --without-gnu-ld
--enable-languages=c,c++,fortran --with-
| mpfr-include=/usr/local/include --with-mpfr-lib=/usr/local/lib
--with-gmp-include=/usr/local/include --with-
| gmp-lib=/usr/local/lib CC=/usr/sfw/bin/gcc CXX=/usr/sfw/bin/g++
| Thread model: posix
| gcc version 4.4.1 (GCC)

I think that this gcc is `/usr/local/gcc-4.4.1-sun-linker/bin/gcc'.
library when gcc compiled it is

if it follows the instruction of FAQ(gcc).

The build is done by using  run time directory in LD_RUN_PATH.
  LD_RUN_PATH=/usr/local/gcc-4.4.1-sun-linker/lib make
You should enumerate the run time directory of gcc in LD_LIBRARY_PATH.

I think that it is a policy of system administration. It is not a problem of R.
There is not the problem in R on Solaris10 which I use.

Sorry in advance if I'm wrong.

2010/6/15 Dr. David Kirkby <david.kirkby at onetel.net>:
> On 06/14/10 10:05 AM, Ei-ji Nakama wrote:
>>> And if you look at the other R-help message posted by David Kirby you
>>> will find a link to the trouble ticket report in Sage as
>>> http://trac.sagemath.org/sage_trac/ticket/9201
>>> From the link,...
>> |  kirkby at t2:[~] $ echo $LD_LIBRARY_PATH
>> |
>> /usr/local/gcc-4.4.1-sun-linker/lib:/usr/local/gcc-4.4.1-sun-linker/lib/sparcv9:/usr/local/lib
>> `/usr/local/gcc-4.4.1-sun-linker/lib/sparcv9' is 64bit, it is unnecessary.
>> I think that this obstructs it.
> This is not the reason. If it picked up the wrong library, then there would
> be a message that there was the wrong ELF class, but no library whatever is
> being found.
> I've tried without the 'sparcv9' in LD_LIBRARY_PATH and it makes no
> difference whatsoever. I've tried on two SPARCs too, running different
> releases of Solaris 10.
> Using 'crle' might work, but that is not really a good answer, as it needs
> root access. It should be possible to install an application like R without
> being root. There is something wrong if LD_LIBRARY_PATH can't be used to
> locate libraries.
> I can build the whole of the Sage source code (around 300 MB) and don't see
> this failure elsewhere. Instead, there are a number of programs which link
> to libgcc_s.so.1.
> I stuck some further information at
> http://trac.sagemath.org/sage_trac/ticket/9201
> but it basically just confirms what I've written above.

EI-JI Nakama  <nakama (a) ki.rim.or.jp>
"\u4e2d\u9593\u6804\u6cbb"  <nakama (a) ki.rim.or.jp>

More information about the R-devel mailing list