[Rd] Failure to load the recommended package Matrix (Was: [R] Can one get a list of recommended packages?)

Dr. David Kirkby david.kirkby at onetel.net
Mon Jun 14 17:23:28 CEST 2010

On 06/14/10 10:05 AM, Ei-ji Nakama wrote:
>> And if you look at the other R-help message posted by David Kirby you
>> will find a link to the trouble ticket report in Sage as
>> http://trac.sagemath.org/sage_trac/ticket/9201
>> From the link,...
> |  kirkby at t2:[~] $ echo $LD_LIBRARY_PATH
> | /usr/local/gcc-4.4.1-sun-linker/lib:/usr/local/gcc-4.4.1-sun-linker/lib/sparcv9:/usr/local/lib
> `/usr/local/gcc-4.4.1-sun-linker/lib/sparcv9' is 64bit, it is unnecessary.
> I think that this obstructs it.

This is not the reason. If it picked up the wrong library, then there would be a 
message that there was the wrong ELF class, but no library whatever is being found.

I've tried without the 'sparcv9' in LD_LIBRARY_PATH and it makes no difference 
whatsoever. I've tried on two SPARCs too, running different releases of Solaris 10.

Using 'crle' might work, but that is not really a good answer, as it needs root 
access. It should be possible to install an application like R without being 
root. There is something wrong if LD_LIBRARY_PATH can't be used to locate 

I can build the whole of the Sage source code (around 300 MB) and don't see this 
failure elsewhere. Instead, there are a number of programs which link to 

I stuck some further information at


but it basically just confirms what I've written above.

More information about the R-devel mailing list