[Rd] Problem installing Biobase on Solaris

Paulo Nuin nuin at genedrift.org
Sat Sep 6 16:49:06 CEST 2008


Thanks a lot for your suggestions. I had problems compiling R with gcc 
on Solaris, that's why I decided to install the pre-compiled version.  I 
am in the process of compiling now using the Sun Studio compiler and it 
is, so far,  working wonderfully. I will continue installing it and if I 
have any other errors I will reply to the list.

Sorry if my questions sounded naive, but I don't have a lot of 
experience with Solaris, I am more a Linux person.

Thanks again


Prof Brian Ripley wrote:
> Is this a pre-compiled R?  If so, please do compile from the sources 
> on your own machine.  The compiler output you show is rather unusually 
> complex and quite likely you are picking up some spurious headers or 
> libraries.
> gcc 3.4.3 is a very old compiler: sunfreeware (which is what you 
> appear to be using) has 3.4.6.
> I don't currently have R built on a Solaris 10 Sparc system (I do on 
> amd64), but we have in the past and will again when we have a box back 
> in production use.  We did find the Sun Studio compiler (which is a 
> free download) worked much more smoothly than gcc and gave better 
> performance.
> On Fri, 5 Sep 2008, Paulo Nuin wrote:
>> Hi
>> I thought of that. We have gcc 3.4.3 installed
>> /gates/sfw10/builds/sfw10-gate/usr/src/cmd/gcc/gcc-3.4.3/configure 
>> --prefix=/usr/sfw --with-as=/usr/sfw/bin/gas --with-gnu-as 
>> --with-ld=/usr/ccs/bin/ld --without-gnu-ld --enable-languages=c,c++ 
>> --enable-shared
>> How to make sure which compiler R is using?
> Look in R_HOME/etc/Makeconf for CC.
>> Thanks in advance
>> Paulo
>> Prof Brian Ripley wrote:
>>> What compiler is this?  This is a compiler issue, not an R one.
>>> My guess is that you are mixing gcc (which has __builtin_isnan) and 
>>> cc (which does not).
>>> On Fri, 5 Sep 2008, Paulo Nuin wrote:
>>>> Hi everyone
>>>> This is my first post to the list. I had experience installing and 
>>>> using Bioconductor on Linux and Windows systems but I am 
>>>> encountering problems installing Biobase on Solaris running on 
>>>> Sparc. The package compilation works fine, with only a warning
>>>> warning: implicit declaration of function `__builtin_isnan'
>>>> the help files are generated but in the end it fails with an error 
>>>> also related __builtin_isnan
>>>> ** building package indices ...
>>>> Error in dyn.load(file, DLLpath = DLLpath, ...) :
>>>> unable to load shared library 
>>>> '/usr/local/lib/R/library/Biobase/libs/Biobase.so':
>>>> ld.so.1: R: fatal: relocation error: file 
>>>> /usr/local/lib/R/library/Biobase/libs/Biobase.so: symbol 
>>>> __builtin_isnan: referenced symbol not found
>>>> Calls: <Anonymous> ... tryCatch -> tryCatchList -> tryCatchOne -> 
>>>> <Anonymous>
>>>> Execution halted
>>>> ERROR: installing package indices failed
>>>> The machine I am using is a Sun SPARC Victoria Falls SunOS 5.10 
>>>> Generic_127111-11 sun4v sparc SUNW,T5140
>>>> I posted this message to the BioC list and it was suggested that I 
>>>> tried installing any R package that needed compilation. I installed 
>>>> the XML package with no problems. Any help is appreciated. Thanks 
>>>> in advance
>>>> Paulo
>>>> ______________________________________________
>>>> R-devel at r-project.org mailing list
>>>> https://stat.ethz.ch/mailman/listinfo/r-devel

More information about the R-devel mailing list