[Rd] R CMD check problem on R 2.6.1 RC

Ulrike Grömping groemp at tfh-berlin.de
Thu Nov 22 18:41:58 CET 2007

Duncan Murdoch-2 wrote:
> On 11/22/2007 10:11 AM, Ulrike Grömping wrote:
>  > Hi Duncan,
>  >
>  > yes, I am talking about a new version (currently called 1.99, to be 
> made 2.0 on release). I don't think I should attach the file in a note 
> to the list - should I ?
>  >
>  > I've just attached the tar-file for you. Please let me know if I 
> should put it somewhere else.
> Sending it to me was fine.  I hope you don't mind me taking the 
> conversation back to the list.
> I don't get an error with 1.99 either, other than this one which isn't 
> your fault:
>  > * checking DESCRIPTION meta-information ... WARNING
>  > Unknown encoding with non-ASCII data
>  > Fields with non-ASCII values:
>  >   Packaged
>  > See the information on DESCRIPTION files in section 'Creating R
>  > packages' of the 'Writing R Extensions' manual.
> This came because R CMD build put the o-umlaut in your name into the 
> Packaged field, i.e. DESCRIPTION has this:
> Packaged: Thu Nov 22 16:06:24 2007; Grömping
> I would call this a bug in our build script, but not one that is serious 
> enough to fix before 2.6.1 gets released.
> In the check log I see at least one use of svydesign with a warning but 
> no error:
>  > ### create design with clusters
>  > des <- svydesign(id=~subj,data=dat)
> Warning in svydesign(id = ~subj, data = dat) :
>    No weights or probabilities supplied, assuming equal probability
> So I'd come back to guessing that you have survey installed in a 
> non-standard place, and R CMD check isn't finding it.
> Duncan Murdoch
> ______________________________________________
> R-devel at r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/r-devel

Actually, survey sits in the very same library with all other packages, and
boot (called from within a relaimpo function) works fine. 
I just fixed the encoding warning (adding "Encoding: latin1" to the
description file), and tried R CMD check once more. Surprisingly, the check
now also ran all examples without errors - I can only guess that there has
been an issue with a path with some nonstandard character in the way (though
survey is not located in such a path). Anyway, it works now.

Regards, Ulrike
View this message in context: http://www.nabble.com/R-CMD-check-problem-on-R-2.6.1-RC-tf4855530.html#a13900659
Sent from the R devel mailing list archive at Nabble.com.

More information about the R-devel mailing list