[Rd] bug in function rpart (PR#9245)

yma at biostat.bsc.gwu.edu yma at biostat.bsc.gwu.edu
Fri Sep 22 16:43:13 CEST 2006

Full_Name: Yong Ma
Version: R 2.3.1
OS: Windows 2000
Submission from: (NULL) (

I have a data set containing 3000 observations. while I was trying to build a
survival tree using the function rpart, I kept getting the following error
>tree<-rpart(coxph(Surv(diabv, diabf) ~ weight, data = sgotdat)) 
 Error in "$<-.data.frame"(`*tmp*`, "yval2", value = c(1, 638)) : 
        replacement has 2 rows, data has 1
It was confusing to me because I was able to use the coxph function on the same
data set with no problem at all. So I googled the internet and found some help
from the following link.


It suggested that the problem has to do with the length of the data. So I tried
a subset of my original data containing 2500 observations and BINGO it worked! 

However, I need to run the analysis on the complete data set and the patch
proposed by Andy is not clear to me how to implement. Please fix the bug

More information about the R-devel mailing list